I'm a newbie-nobody, but I thought I'd chime in that I have nothing against GitHub but I really like SourceForge and what they've done for the community over the years.
Also, not having to use the alphabet-soup crap that is the default GL commands most of the time is really nice, and I'm disappointed about moving away from that (though I understand why). I think it's much cleaner and more readable to do glUniform(id, (float)0, (float)6.1) (and even more clear using parameter values instead, so they're already cast) instead of glUniform2f.
I also am going to miss being able to do things like glGetUniformLocation(Id,"Name"). To do GL subroutines, I basically had to copy code from APIUtils and reimplement it, because glGetSubroutineIndex and glUniformSubroutinesu require buffers (and oh lord, is that 'u' at the end of that name confusing and annoying).
Like I said...I read the rationale posted about switching back to the GL-style names, and I can't disagree with your reasoning...but I still prefer the cleaner way. I just see those weird names as a hack to get around C's lack of typing which Java has.