Btw, what's the current status on 3.0? I've seen several references made to it.
(...) Current focus is on getting osx and java7 to play nicely.
One thing we need to do to attract more contributions is move the codebase to Git and host LWJGL on github, asap. Git is more powerful and popular than SVN (I honestly only use SVN for LWJGL, all other OS projects use Git or some other DCVS), it would be very convenient for potential contributors to not have to go through SVN's shitness. Also, github's pull request automation is too awesome.
@spasi that sounds really cool, please if you could start a new RFE thread so that we can start listing, discussing and narrowing down what 3.0 will and will not be. Should help focus where we want to go. Also got a list somewhere in one of my projects where I've been storing API complaints that ppl have been complaining about over the years which we can fix in 3.0.
As for GIT, SourceForge also supports that now, not sure if its any good compared some of the more hyped services like GitHub and BitBucket. However one could still argue that SVN isn't broken and still works well enough but still its slow now, no built in support in Eclipse and all the cool kids are using Git now.
Also, not having to use the alphabet-soup crap that is the default GL commands most of the time is really nice, and I'm disappointed about moving away from that (though I understand why). I think it's much cleaner and more readable to do glUniform(id, (float)0, (float)6.1) (and even more clear using parameter values instead, so they're already cast) instead of glUniform2f.I also am going to miss being able to do things like glGetUniformLocation(Id,"Name"). To do GL subroutines, I basically had to copy code from APIUtils and reimplement it, because glGetSubroutineIndex and glUniformSubroutinesu require buffers (and oh lord, is that 'u' at the end of that name confusing and annoying).Like I said...I read the rationale posted about switching back to the GL-style names, and I can't disagree with your reasoning...but I still prefer the cleaner way. I just see those weird names as a hack to get around C's lack of typing which Java has.