Hello Guest

[RFE / Bug] getting wrong context versions

  • 1 Replies
  • 3316 Views
[RFE / Bug] getting wrong context versions
« on: May 01, 2014, 19:54:12 »
I'm having the problem described here: http://lwjgl.org/forum/index.php/topic,5349.0.html

I'm on OS X 10.9
I want a 3.3 core context. Asking for one returns a 2.1 non-core context. Asking for a 3.2 core context returns a 4.1 core context.

*

Offline spasi

  • *****
  • 2153
    • WebHotelier
Re: [RFE / Bug] getting wrong context versions
« Reply #1 on: May 02, 2014, 20:13:33 »
This has been fixed, please try the next nightly build.

Note that, on OS X, you should always check the context's OpenGL version. You could ask for OpenGL 3.3 but get a 3.2 context instead. Also, it's perfectly normal to get a 4.1 context when asking for 3.2 or 3.3. Basically, the version specified in ContextAttribs makes no difference, as long as it's >= 3.2 (with the core profile).