Hello Guest

[SOLVED] LWJGL3 Linux Eclipse "symbol lookup error"

  • 3 Replies
  • 3249 Views
*

Offline Lugen

  • *
  • 18
[SOLVED] LWJGL3 Linux Eclipse "symbol lookup error"
« on: July 03, 2015, 23:41:26 »
Greetings one and all!

Hope this is the right section of the forum to post about this issue I'm having.

So I'm trying to get started with LWJGL3. Never used any of the previous versions before.
I set up the project in Eclipse and everything seems to be in order. Running the code below works.

Code: [Select]
import org.lwjgl.Sys;

public class TestSetup {

    public static void main(String[] args) {
        System.out.println("LWJGL Version " + Sys.getVersion() + " is working.");
    }
}

However when I try to initialize GLFW, specifically by calling this function which seems to be vital in setting up a window judging from the examples I've seen,
Code: [Select]
if (glfwInit() == GL_FALSE)
When running the program nothing happens except termination and this message in the Console output.
/usr/lib/jvm/java-8-oracle/bin/java: symbol lookup error: /*path*/native/liblwjgl.so: undefined symbol: clock_gettime

Been searching here and about but can't seem to find any similar issues like this which is a bummer since I'm quite excited to start using LWJGL.

Additionally, in case it matters I'm on Ubuntu 12.04 64-bit.
« Last Edit: July 05, 2015, 10:36:59 by Lugen »

*

Offline spasi

  • *****
  • 2191
    • WebHotelier
Re: LWJGL3 Linux Eclipse "symbol lookup error"
« Reply #1 on: July 04, 2015, 13:22:38 »
Hey Lugen,

Could you try this build please?

*

Offline Lugen

  • *
  • 18
Re: LWJGL3 Linux Eclipse "symbol lookup error"
« Reply #2 on: July 04, 2015, 13:40:27 »
Hey Lugen,

Could you try this build please?

Holy stuff, it works! Tested with this code.
https://github.com/SilverTiger/lwjgl3-tutorial/blob/master/src/silvertiger/tutorial/lwjgl/Introduction.java

Thanks a bunch! So I guess there was something missing from the previous build? Maybe worth to mention that previously I tried all the three builds available on the download page, which gave the same error result.

*

Offline spasi

  • *****
  • 2191
    • WebHotelier
Re: LWJGL3 Linux Eclipse "symbol lookup error"
« Reply #3 on: July 04, 2015, 13:54:21 »
Holy stuff, it works!

Cool, thanks for the confirmation.

Maybe worth to mention that previously I tried all the three builds available on the download page, which gave the same error result.

The nightly and stable builds have been updated now.