Hello Guest

[BUG]Java 13 upgrade: SEVERE: System Exception - no lwjgl in java.library.path:

  • 0 Replies
  • 1935 Views
I've been running this fine with java 12 and below, but decided to run this with the java13 runtime today and had the below issue:

SEVERE: System Exception - no lwjgl in java.library.path:
   at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2670)
   at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:806)
   at java.base/java.lang.System.loadLibrary(System.java:1906)
   at org.lwjgl.Sys$1.run(Sys.java:73)
   at java.base/java.security.AccessController.doPrivileged(AccessController.java:312)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
   at org.lwjgl.Sys.loadLibrary(Sys.java:95)
   at org.lwjgl.Sys.<clinit>(Sys.java:112)
   at org.lwjgl.opengl.GLContext.<clinit>(GLContext.java:112)
   at com.utility.software.is.awesome.threed.util.JOGLUtil.tryLoadLibrary(JOGLUtil.java:407)
   at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
   at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
   at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
   at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
   at java.base/java.lang.Thread.run(Thread.java:830)


This is running on Linux64 with the 2.8.4 release.
Literally all I've done is changed the jre from 12 to 13, the rest of the set up is 100% the same (I know this because we're running this with a bash script that keeps it all constant).

Is there something else I need to be doing here to get this to work?
« Last Edit: November 10, 2021, 23:14:12 by ArgyVonBargy »