Hello Guest

[SOLVED] org.lwjgl.opengl.WGL on AMD RX 580

  • 2 Replies
[SOLVED] org.lwjgl.opengl.WGL on AMD RX 580
« on: February 14, 2020, 09:08:44 »
a dev of the gaiasky project https://zah.uni-heidelberg.de/institutes/ari/gaia/outreach/gaiasky/ assumes that the crash of the application might be a bug in the lwjgl in association with AMD Graphics Card ..


I used the search option in this forum here, but did not get results according to my problem:

java.lang.NoClassDefFoundError: Could not initialize class org.lwjgl.opengl.WGL$Functions

Maybe someone can give a hint where to dig instead...

Thank you
« Last Edit: February 18, 2020, 07:18:00 by robidoo »

Re: [BUG] org.lwjgl.opengl.WGL on AMD RX 580
« Reply #1 on: February 14, 2020, 10:32:12 »
this is most likely not an issue with LWJGL but with the library's gaiasky.util.VMemInfo.ATIVRAM. Despite the class using Windows-specific functionality (WGL), it seems to be used when running on an unix-based OS based on your crash report.
The application should check which OS it's currently running on and which extensions are supported before using WGLAMDGPUAssociation (or GLXAMDGPUAssociation).

Re: [BUG] org.lwjgl.opengl.WGL on AMD RX 580
« Reply #2 on: February 18, 2020, 07:17:36 »
Thank you very much for the precise analysis!

Based on your comment the dev of the gaiasky app was able to figure out the problem in the code and fixed it - works now!