Hello Guest

[FIXED] LWJGL screws up dual screen setup in Linux

  • 3 Replies
  • 5821 Views
[FIXED] LWJGL screws up dual screen setup in Linux
« on: April 04, 2010, 03:57:35 »
Hello.  I'm using Gentoo Linux with the xf86-video-ati driver.  I have two screens setup using xrandr 1.3.2

When I use the GLGears demo, it works fine until I close it.  Once I close it, it screws up my setup by shutting off one screen.  I have to manually re-enable it everytime I run something using LWJGL.  This is if I run the demo in a window, so it's not a fullscreening issue.

I'm trying to make something with LWJGL, but this is driving me insane.

*

Offline Matzon

  • *****
  • 2242
Re: LWJGL screws up dual screen setup in Linux
« Reply #1 on: April 04, 2010, 06:59:28 »
Hello.  I'm using Gentoo Linux with the xf86-video-ati driver.  I have two screens setup using xrandr 1.3.2

When I use the GLGears demo, it works fine until I close it.  Once I close it, it screws up my setup by shutting off one screen.  I have to manually re-enable it everytime I run something using LWJGL.  This is if I run the demo in a window, so it's not a fullscreening issue.

I'm trying to make something with LWJGL, but this is driving me insane.

use LWJGL 2.4 nightly http://lwjgl.org/download.php

Re: LWJGL screws up dual screen setup in Linux
« Reply #2 on: April 04, 2010, 16:26:14 »
Awesome it works.   ;D

Just curious, was this fixed a while ago, or did you just fix it after finding the thread?

*

Offline kappa

  • *****
  • 1314
Re: LWJGL screws up dual screen setup in Linux
« Reply #3 on: April 04, 2010, 16:29:29 »
a while ago.

see this thread for more info http://lwjgl.org/forum/index.php/topic,3225.0.html