Hello Guest

LWJGLException during installation test on linux

  • 2 Replies
  • 7706 Views
LWJGLException during installation test on linux
« on: April 29, 2009, 20:32:49 »
Hi there,

after years of experiencing stability issues, lack of support and dying development of various multimedia-related Java libraries, I thought I'd give the renowned JLWJL a try. However, after downloading & unzipping the package, I got the following output when performing the recommended test at the command prompt (Debian Sid on AMD64, but running a 686 kernel; Java is 1.6.0_13-b03, and xorg is 1.7.4):

Code: [Select]
The following keys are available:
ESCAPE:         Exit test
ARROW Keys:     Move window when in non-fullscreen mode
L:              List selectable display modes
0-8:            Selection of display modes
F:              Toggle fullscreen
SHIFT-F:        Toggle fullscreen with Display.destroy()/create() cycle
Found 18 display modes
Problem retrieving mode with 640x480x16@-1
Problem retrieving mode with 640x480x32@-1
Problem retrieving mode with 800x600x16@-1
Problem retrieving mode with 800x600x32@-1
Problem retrieving mode with 1024x768x16@-1
Problem retrieving mode with 1024x768x32@-1
org.lwjgl.LWJGLException: X Error - disp: 0x86acc10 serial: 36 error: BadMatch (invalid parameter attributes) request_code: 1 minor_code: 0
        at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:284)
        at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)
        at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:429)
        at org.lwjgl.opengl.Display.createWindow(Display.java:308)
        at org.lwjgl.opengl.Display.create(Display.java:839)
        at org.lwjgl.opengl.Display.create(Display.java:767)
        at org.lwjgl.opengl.Display.create(Display.java:748)
        at org.lwjgl.test.WindowCreationTest.initialize(WindowCreationTest.java:92)
        at org.lwjgl.test.WindowCreationTest.main(WindowCreationTest.java:284)

I suppose that's also the reason why all graphics-related web start apps listed on http://lwjgl.org/demos.php fail to get going.

Anyone any idea what might be the cause of the trouble?

Regards --

tcrass


P.S. Here's what lspci says about my graphics card:

Code: [Select]
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)

*

Offline Matzon

  • *****
  • 2242
Re: LWJGLException during installation test on linux
« Reply #1 on: April 29, 2009, 22:11:12 »

Re: LWJGLException during installation test on linux
« Reply #2 on: April 30, 2009, 08:58:11 »
as per http://lwjgl.org/forum/index.php?topic=2889 - try the nightly

Ah, sorry, missed that one -- yepp, it's working now, thanks! :-)

Any chance for an official bug fix release anytime soon?

Regards --

tcrass