Hello Guest

java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat

  • 6 Replies
  • 29248 Views
java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« on: November 23, 2005, 19:51:14 »
Hi,
I have some problems with the libarys. I don't know, how to include them. I'm usually using JBuilder from Borland.
The import statements seem to be correct. No compiler error occurs.
On http://www.lwjgl.org/faq.php is stated, that it is necessary to "Specify the path to it using -Djava.library.path=<path/to/library>".
I have an idea what that means, but I don't know what to do exactly.
Thanks
Diggi

*

Offline lightbringer

  • **
  • 50
  • Lone Wolf
java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« Reply #1 on: November 23, 2005, 21:16:54 »
The library path is where you put all those dll files that came with lwjgl. let's say your libraries are in c:\bin then you need to pass "-Djava.library.path=c:\bin" to the java vm at runtime. From the command line you would do something like

javaw.exe -Djava.library.path=c:\bin -jar yourgame.jar

but you're using JBuilder - I'm not familiar with it but look for "VM Arguments" or some such in the configuration settings or the settings for the execution if you run your project from within jbuilder.

Alternatively, you could put the dll's in the same directory as where you are executing the project from, since the current working directory should be in the library path already iirc.

java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« Reply #2 on: November 23, 2005, 21:52:15 »
thanks that works

doesn't work for me ...
« Reply #3 on: May 27, 2006, 09:38:57 »
how can I adapt your answer to my configuration ?

I'm using NetBeans 5.0 under Linux Debian Sarge and having the same issue with the exact same error line:
Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

what could I do ?
thx in advance

*

Offline lightbringer

  • **
  • 50
  • Lone Wolf
java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« Reply #4 on: May 27, 2006, 15:27:11 »
you realise this topic is half a year old, right? :D

I don't know about NetBeans nor about java under linux, but from the command line in the correct directory I guess you could try something like

javaw -Djava.library.path=./bin -jar yourgame.jar

assuming a subdir called bin that contains the lwjgl jars

java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« Reply #5 on: May 27, 2006, 15:36:07 »
thanks for u'r help but unfortunately it still doesn't work ... I tried every possible way as far as I know and I just can't make it play any music :(

this is what I launched :
/opt/jdk1.5.0_06/jre/bin/java -Djava.library.path=/home/louis/CoursENS/PPOOGL/jpct/lib/lwjgl-0.99/ -jar "/home/louis/CoursENS/PPOOGL/jpct/examples/car/dist/Car.jar"

where /opt/jdk1.5xxxx/jre/bin is the directory where java lies
and /home/louis/CoursENS/PPOOGL/jpct/lib/lwjgl-0.99 is the lib directory ...

Does anyone have a hint ?
L.

java.lang.UnsatisfiedLinkError: no lwjgl in java.libary.pat
« Reply #6 on: May 28, 2006, 14:24:37 »
Hmm,
you must be pointing to the wrong directory, probably the base install dir, and not the native dir with the so files...
I haven't tried it on the linux box, but sending the display over network for playing games usually works very badly. ;)
Under project properties go to Run and set VM Options to:

-Djava.library.path=/home/louis/CoursENS/PPOOGL/jpct/ib/lwjgl-0.99/native/

I'm pretty sure that's the problem...
So add native to the end of that path...
igg -- Take me off for great justice?