Hello Guest

Importing and Using LWJGL3 with Ecplise

  • 0 Replies
  • 18 Views
Importing and Using LWJGL3 with Ecplise
« on: April 09, 2021, 11:51:14 »
Hey guys.
Newest as can be, wanna pick up a new hobby, so I wanna tinker a bit with lwjgl.
anyway, sorry in advance for TLDR but:

-> I downloaded all needed jars, sources, docs, natives,
-> I created a new User Library in Ecplise, importing all the necessary jars, and attaching the sources and javadocs as needed.
->  I created a project and added the new User Library to the build path.

So far so good,
Then I tried running the example code from https://www.lwjgl.org/guide,
now I can import lwjgl.* and it even identifies it (I see information tooltip while hovering over the import in eclipse), allowing me to jump to source and whatnot,
but can't use any functionality because everything throws "NoClassDefFoundError",

this is the exact error I get when trying to run (with no errors / warnings prompted by eclipse prior to running):
Code: [Select]
Exception in thread "main" java.lang.NoClassDefFoundError: org/lwjgl/Version
at HelloWorld.run(HelloWorld.java:20)
at HelloWorld.main(HelloWorld.java:112)
Caused by: java.lang.ClassNotFoundException: org.lwjgl.Version
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:606)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:168)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
... 2 more

Looking at the project explorer, I can see all the lwjgl within the user library I created, and I can jump to source, but can't seem to run it,
what am I missing? I got all the class files, but eclipse doesn't seem to recognize... or care

Thanks guys!