Hello Guest

glx problems with linux drivers

  • 0 Replies
  • 198 Views
glx problems with linux drivers
« on: June 01, 2022, 17:17:00 »
Hi, I would like to learn lwjgl, but can not even start to code something because of the errors
maybe someone here could help me

Code: [Select]
[LWJGL] GLFW_API_UNAVAILABLE error
Description : GLX: No GLXFBConfigs returned
Stacktrace  :
org.lwjgl.glfw.GLFW.nglfwCreateWindow(GLFW.java:2024)
org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:2197)
HelloWorld.init(HelloWorld.java:49)
HelloWorld.run(HelloWorld.java:22)
HelloWorld.main(HelloWorld.java:114)
[LWJGL] GLFW_FORMAT_UNAVAILABLE error
Description : GLX: Failed to find a suitable GLXFBConfig
Stacktrace  :
org.lwjgl.glfw.GLFW.nglfwCreateWindow(GLFW.java:2024)
org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:2197)
HelloWorld.init(HelloWorld.java:49)
HelloWorld.run(HelloWorld.java:22)
HelloWorld.main(HelloWorld.java:114)
Exception in thread "main" java.lang.RuntimeException: Failed to create the GLFW window
at HelloWorld.init(HelloWorld.java:51)
at HelloWorld.run(HelloWorld.java:22)
at HelloWorld.main(HelloWorld.java:114)

Process finished with exit code 1

from debugging I can only get that:
Code: [Select]
{Integer@1165} 65537 -> "GLFW_NOT_INITIALIZED"
{Integer@1167} 65539 -> "GLFW_INVALID_ENUM"
{Integer@1169} 65538 -> "GLFW_NO_CURRENT_CONTEXT"
{Integer@1171} 65541 -> "GLFW_OUT_OF_MEMORY"
{Integer@1173} 65540 -> "GLFW_INVALID_VALUE"
{Integer@1175} 65543 -> "GLFW_VERSION_UNAVAILABLE"
{Integer@1177} 65542 -> "GLFW_API_UNAVAILABLE"
{Integer@1179} 65545 -> "GLFW_FORMAT_UNAVAILABLE"
{Integer@1181} 65544 -> "GLFW_PLATFORM_ERROR"
{Integer@1183} 65547 -> "GLFW_CURSOR_UNAVAILABLE"
{Integer@1185} 65546 -> "GLFW_NO_WINDOW_CONTEXT"
{Integer@1187} 65549 -> "GLFW_FEATURE_UNIMPLEMENTED"
{Integer@1189} 65548 -> "GLFW_FEATURE_UNAVAILABLE"
{Integer@1191} 65550 -> "GLFW_PLATFORM_UNAVAILABLE"

my system: Linux Mint, nvidia 2060, 510 drivers, IntelliJ, example from the lwjgl page
tested also lwjglbook from git

I can start the hello world IF I uninstall the Nvidia dirvers
-mesa works
-Nuveau drivers works

but both have really bad performance and crashes other applications, so I would like to keep Nvidia blobb drivers if possible

:~$ sudo glxinfo | grep "GLX version"

GLX version: 1.4

libglfw3 is already the newest version (3.3.2-1).


glxgears works
3d stuff like my 2-3 steam games works also

I asked already 1 week ago on stackoverflow-> no answers, but an -2 rating for asking questions in the toxic community
I asked 2 days ago on Nvidia forum-> no answers

edit2:

maybe solved
root cause was (partly)broken IntelliJ installation from flatpak  :o

actually I can keep the faster drivers and hello world is working :)
« Last Edit: June 03, 2022, 17:00:14 by NotEvil »