Hello Guest

LWJGL 0.92 released!

  • 26 Replies
  • 14758 Views
*

Offline Matzon

  • *****
  • 2242
LWJGL 0.92 released!
« Reply #15 on: September 08, 2004, 20:25:14 »
meh, we'll do a release soon again. probalby this weekend. The library was build without support for wglAllocateMemoryNV due to a small bug (missing undersocre in a define!). Everything else should work fine.

Linux native build
« Reply #16 on: September 09, 2004, 05:29:32 »
Hi...

I was happy to see there is a new release of lwjgl and immediatly downloaded it. I tried to compile it on my linux box but failed at first while compile_java... there is no java target given in the build.xml as in the previus version...
I added source="1.4" to all javac tags in build.xml and that worked just fine...
But now ant stopps in compile_native :oops: :
Code: [Select]

compile_native:

-compile_native_win32:

-compile_native_linux:
     [echo] Compiling Linux LWJGL version
    [apply] /home/mci/java/lwjgl0.92/lwjgl-source-0.92/src/native/build.sh: line 2:
    [apply] : command not found/home/mci/java/lwjgl0.92/lwjgl-source-0.92/src/native/build.sh: line 3: ./autogen.sh
    [apply] : No such file or directory/home/mci/java/lwjgl0.92/lwjgl-source-0.92/src/native/build.sh: line 4: ./configure
    [apply] : No such file or directory/home/mci/java/lwjgl0.92/lwjgl-source-0.92/src/native/build.sh: line 5: make
    [apply] : command not foundstrip: '.libs/liblwjgl.0.0.0
    [apply] ': No such file


I don't really know what to do... Has anybody the same problem or maybe  a solution?

*

Offline Matzon

  • *****
  • 2242
LWJGL 0.92 released!
« Reply #17 on: September 09, 2004, 07:32:37 »
please manually navigate to /home/mci/java/lwjgl0.92/lwjgl-source-0.92/src/native
and type ./build.sh

what is the output from this?

do you have:
aclocal
autoheader
automake
autoconf
gcc

installed?

manuell test
« Reply #18 on: September 09, 2004, 11:23:29 »
yes sir ;)

ok, bash.sh has no permission zu execute, if i do 'sh build.sh'
Code: [Select]

build.sh: line 2:
: command not found
build.sh: line 3: ./autogen.sh
: No such file or directory
build.sh: line 4: ./configure
: No such file or directory
build.sh: line 5: make
: command not found
strip: '.libs/liblwjgl.0.0.0
': No such file

when i do 'chmod +x bash.sh' and try to execute it with ./build.sh
Code: [Select]
: bad interpreter: No such file or directory

Shure I have all the programms you listed: :-D
aclocal 1.4-p6
autoheader 2.13
automake 1.4-p6
autoconf 2.13
gcc 3.3.4

I'm running gentoo, ant 1.6.2 and java 1.4.2_05 from sun

*

Offline Matzon

  • *****
  • 2242
LWJGL 0.92 released!
« Reply #19 on: September 09, 2004, 11:43:15 »
You have read this thread:
http://puppygames.net/forums/viewtopic.php?t=642&postdays=0&postorder=asc&start=15

?

coult you check for white space and similar in the file?
bad interpreter sounds odd - I am sure you can run bash :)

White Spaces
« Reply #20 on: September 09, 2004, 12:52:04 »
yes there where some whitespaces in the files build.sh and autogen.sh

and I had to do the same procedures as the lwjgl version before.(setting JAVAC to "" and change build.xml to source="1.4")

but now I have a new problem i can't resolve... sorry for bugging
Code: [Select]

[apply] configure: creating ./config.status
    [apply] config.status: creating Makefile
    [apply] config.status: error: cannot find input file: Makefile
    [apply] .inmake: *** No targets specified and no makefile found.  Stop.


what now? Did I forgott something?

*

Offline Matzon

  • *****
  • 2242
LWJGL 0.92 released!
« Reply #21 on: September 09, 2004, 12:57:44 »
you need to run autogen.sh first

*

Offline mac

  • *
  • 37
    • http://www.mac-systems.de
Method not supported yet ?
« Reply #22 on: September 09, 2004, 16:11:23 »
Hi,

i played a bit with that fmod stuff and tried to read the playback lenght of a file in mills using

Code: [Select]

boolean FSOUND_Stream_GetLengthMs(FSoundStream handle);


the return type makes not much sense ?
or is it simpy not supported yet ?


 - jens
he Network is the Music
www.mac-systems.de

*

Offline Matzon

  • *****
  • 2242
Re: Method not supported yet ?
« Reply #23 on: September 09, 2004, 16:20:32 »
Quote from: "mac"
the return type makes not much sense ?
Indeed it doesn't! - it's a bug. Will fix shortly :)

*

kevglass

LWJGL 0.92 released!
« Reply #24 on: September 10, 2004, 07:35:17 »
After a brief discussion on #lwjgl I was under the impression that the current .so release of LWJGL wasn't going to work on Mandrake Beta.

I finally installed it + nvidia drivers etc.. and it works! Woo hoo!

Thanks for the new release guys,

Kev

*

Offline Matzon

  • *****
  • 2242
LWJGL 0.92 released!
« Reply #25 on: September 10, 2004, 07:40:22 »
nah, we talked about the 10.1 RC1 release. What you installed was probably 10.0?

*

kevglass

LWJGL 0.92 released!
« Reply #26 on: September 10, 2004, 09:43:09 »
Ah ha! Thanks for clearing that up. Makes sense sort of :)

Kev