New download of LWJGL missing classes

Started by NexoKnight12, October 09, 2018, 18:12:48

Previous topic - Next topic


I downloaded LWJGL as a .zip, from their site. On their Wiki, they provide an example game of Space Invaders, with 10 different classes. The first class I tried to copy, IntelliJ gave me the error that it couldn't find ANY of the import statements. I have unpacked and added the .zip to my project classpath, and as a library. The snippet of code on the LWJGL "Getting Started" worked fine. I can go through the .jar files on the left, and the classes being used by the game are not in their corresponding .jars.

For example, the first class the game tries to import is:

import static org.lwjgl.LWJGLException;

But in the lwjgl.jar, under org.lwjgl, the only classes and interfaces are:





I can import any of these without problem, but why am I missing all these classes? Is there something I needed to set up before I can use LWJGL? (I am running Linux, Ubuntu 64bit)


I m afraid that the example was for lwgjl 2 and you downloaded lwgjl 3.


Quote from: Risa123 on December 11, 2018, 15:47:23
I m afraid that the example was for lwjgll 2 and you downloaded lwjgl 3.