[SOLVED] Error 65543 when launching from Steam

Started by Obsyd, July 03, 2018, 09:43:39

Previous topic - Next topic


Hello there!

I'm on Fedora 28 with 390.67 nvidia prop drivers. All is fine OGL 4.5  is working. (oh even 4.6 is working) As far as I know Fedora 28 is using wayland but "echo $WAYLAND_DISPLAY" returns with nothing and "loginctl show-session <mysessionnum> -p Type" returns with Type=x11.
I'm using packr to create an executable for my project. When I run my JAR with java -jar all is fine, when I run the packr created executable by double clicking or by terminal all is fine.
But when Steam tries to launch the executable I get this error:
GLFW ERROR detected! Error ID: 65543 error long: 140733324113168

I googled around and it seems like an opengl error, but how can that be? Because all other launch methods work fine except from Steam.
GLFW is able to init and sees proper resolutions and refresh rates.
I also disabled Steam overlay but no luck.

Has anyone had a problem like this?



Well, turns out I simply needed to install additional packages... with the "sudo flatpak update" command. Since I installed Steam via flatpak. This installed org.freedesktop.Platform.GL.nvidia-390-67/x86_64/1.4.
Can anyone tell me how is that the flatpak system needs its own GL packages and cannot simply use the base system's GL?