Hello Guest

Excelsior Jet and lwjgl 3.1.x = crash since Test Run stopped....

  • 9 Replies
  • 344 Views
Hello everyone,

I will report that because I have tried x86 and x64 with Excelsior Jet 15
And It said after "Test run" - If I have checked lwjgl 3.1 with Excelsior Jet 15 than it stopped because it looks
Code: [Select]
[LWJGL] Failed to retrieve the JVMTI interface pointer.
JET RUNTIME HAS DETECTED UNRECOVERABLE ERROR: system exception at 0x00007ffdde143bb9
Please, contact Excelsior Support at <java@excelsior-usa.com>.
Crash dump will be written to "C:\Users\SSB\Documents\MyDevJava\TestWithATSWING\SwtDemo\jet_dump_12180.dmp"
Extra information about error is saved in the "jet_err_12180.txt" file.

Cause it is NullException error when you made jar unpack any dlls / so / dylib
Please go back old structure of lwjgl 2.9.3

Workaround with old lwjgl = works fine.
I have tested lwjgl 2.9.3 and swt into Excelsior Jet = Working 100 %

It is truth bundled executable of Excelsior Jet


But why does it not work with lwjgl 3.1.6/3.1.7? Please fix it!

And check community of Excelsior Jet 15 I have written there.

Thanks!

*

Offline spasi

  • *****
  • 2016
    • WebHotelier
Excelsior JET does not support JVMTI. LWJGL requires JVMTI for the OpenGL and OpenGL ES bindings only, it is used to avoid a thread-local lookup per function call.

This issue is not acceptable, I'll post again when I figure out a solution.

Oh?

How do we protect own game? - who want sell or share nice lwjgl games on Steam, Origin or other Game-Managers and hackers are happy to decompile java classes and they are spying to own game. If game has connection with store like coins, cashes or assets for game like FarmVile or  Samuari Siege etc..

Please respect to us! We love protector Excelsior Jet 15.x because hackers can't decompile it.

Please give chance with lwjgl 3.x!

*

Offline spasi

  • *****
  • 2016
    • WebHotelier
I have a feeling you misunderstood my answer. This is a critical issue for LWJGL and I'll try to resolve it as soon as possible. LWJGL must support Excelsior Jet and other AOT compilers.

I am sorry I found wikipedia https://en.wikipedia.org/wiki/Java_Virtual_Machine_Tools_Interface

I understand you now like you mean JVMTI. For Excelsior Jet has only AOT like Mono Project

That is why Excelsior Jet need add new feature of JVMTI.

*

Offline spasi

  • *****
  • 2016
    • WebHotelier
Excelsior JET won't add it because "its implementation would enable a wide variety of introspection techniques for the compiled applications, which is highly undesirable".

The problem is that the GL/GLES bindings depend on an optional JVM feature to work. There has to be a fallback implementation when it's not available.

*

Offline spasi

  • *****
  • 2016
    • WebHotelier
Hey sourceskyboxer,

Could you please try LWJGL 3.1.7 snapshot build 7? The dependency to JVMTI has been eliminated.

*

Offline spasi

  • *****
  • 2016
    • WebHotelier
I just tried with the Gears demo and an evaluation copy of Excelsior JET 15, the executable worked perfectly. Please confirm when you have time.

Re: Excelsior Jet and lwjgl 3.1.x = crash since Test Run stopped....
« Reply #8 on: August 08, 2018, 01:44:02 »
I just tried with the Gears demo and an evaluation copy of Excelsior JET 15, the executable worked perfectly. Please confirm when you have time.

I am sorry for long time. I am busy from my work. I need eadn money.  I am sorry i will check lwjgl and Excelsior jet. Thanks

Re: Excelsior Jet and lwjgl 3.1.x = crash since Test Run stopped....
« Reply #9 on: August 09, 2018, 09:29:50 »
Wow it works now! Thank you for resolving it! I am sorry for longer busy. Thanks, Magicians!