LWJGL Forum

Please login or register.

Login with username, password and session length

Author Topic: [CLOSED] LWJGL The driver does not appear to support OpenGL  (Read 856 times)

Brouilles

  • Newbie
  • *
  • Offline Offline
  • Posts: 4

Hello,
I have been working on my project for several weeks without any worries. Except for a few days impossible to launch it, I find myself with the following error:
Code: [Select]
[LWJGL] GLFW_API_UNAVAILABLE error
Description : WGL: The driver does not appear to support OpenGL
Stacktrace  :
org.lwjgl.glfw.GLFW.nglfwCreateWindow(GLFW.java:1251)
org.lwjgl.glfw.GLFW.glfwCreateWindow(GLFW.java:1412)
com.dezeiraud.engine.Display.init(Display.java:74)
com.dezeiraud.engine.Display.<init>(Display.java:54)
com.dezeiraud.engine.CoreEngine.<init>(CoreEngine.java:53)
com.dezeiraud.main.Main.main(Main.java:13)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
java.lang.reflect.Method.invoke(Method.java:498)
com.intellij.rt.execution.application.AppMain.main(AppMain.java:147)

The only explanation would be that I upgraded my driver with GeForce experience (GeForce GTX 560 Ti and Driver version 378.49). So I have to look if I do not turn on Intel chipset but apparently not ... The problem does not come I do not think of LWJGL nor GLFW but if you have a solution I am taker.

Thank you for your reply,
Best regards.
Logged

spasi

  • Administrator
  • Nerdus Imperius
  • *****
  • Offline Offline
  • Posts: 1835
Re: [BUG] LWJGL The driver does not appear to support OpenGL
« Reply #1 on: January 28, 2017, 18:22:32 »

The latest Nvidia driver is broken, read this reply.
Logged

Brouilles

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: [CLOSED] LWJGL The driver does not appear to support OpenGL
« Reply #2 on: January 28, 2017, 19:20:28 »

Thank you for your reply. I'll see if it's possible to go back or so if with the beta drivers it works.
Thanks again
Logged