Hello Guest

XRandR problem with custom monitor resolution on lwjgl-2.9.3

  • 0 Replies
  • 1704 Views
Hi to all.
I had an issue on Ubuntu-Linux (16.04.01 LTS) with Display Settings.
The Error Message is the same, as on following post:
http://forum.lwjgl.org/index.php?topic=6088.msg32594#msg32594

The problem is the appended "_60.00" to resolution.
Because it is a common way on linux to set custom displaysettings from modline lwjgl should take care of this, I think.

Here the output from xrandr and cvt
Quote
ppp@ppp-desktop:~/svn/MyGame$ /usr/bin/xrandr -q
Screen 0: minimum 320 x 200, current 1368 x 768, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected primary 1368x768+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1368x768_60.00  59.88*+
   1920x1080     60.00 +
   1600x1200     60.00 
   1680x1050     59.95 
   1400x1050     59.98 
   1280x1024     75.02    60.02 
   1440x900      59.89 
   1280x960      60.00 
   1152x864      75.00 
   1024x768      75.08    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00 
   720x400       70.08 
ppp@ppp-desktop:~/svn/MyGame$ cvt 1368 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
ppp@ppp-desktop:~/svn/MyGame$

The problem was solved after deleting the appended "_60.00" in my Xorg.conf settings:
/usr/share/X11/xorg.conf.d/40-monitor.conf