Hello Guest

[Help] [Solved] Problem with LWJGL 2.9.4 (Nightly builds)

  • 0 Replies
[Help] [Solved] Problem with LWJGL 2.9.4 (Nightly builds)
« on: January 06, 2016, 01:52:16 »
Well, the thing is that I have a problem with Minecraft 1.8.8; Running Ubuntu 15.10, with an unsupported monitor (those that need their resolutions specified in xorg.conf file)

Mostly I need to be sure who's to "blame" as a matter of speaking but I couldn't find a general discussion forum.
I have to say that earlier versions of Minecraft (ie. 1.7.2 - using lwjgl 2.9.0) worked flawlessly.

The LWJGL version as specified by the launcher is: lwjgl-2.9.4-nightly-20150209.jar
Code: [Select]
Cliente> java.lang.ExceptionInInitializerError
Cliente> at ave.ar(SourceFile:560)
Cliente> at ave.am(SourceFile:361)
Cliente> at ave.a(SourceFile:310)
Cliente> at net.minecraft.client.main.Main.main(SourceFile:124)
Cliente> Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
Cliente> at org.lwjgl.opengl.XRandR.findPrimary(XRandR.java:326)
Cliente> at org.lwjgl.opengl.XRandR.ScreentoDisplayMode(XRandR.java:315)
Cliente> at org.lwjgl.opengl.LinuxDisplay$3.run(LinuxDisplay.java:746)
Cliente> at org.lwjgl.opengl.LinuxDisplay$3.run(LinuxDisplay.java:743)
Cliente> at java.security.AccessController.doPrivileged(Native Method)
Cliente> at org.lwjgl.opengl.LinuxDisplay.init(LinuxDisplay.java:743)
Cliente> at org.lwjgl.opengl.Display.<clinit>(Display.java:138)
Cliente> ... 4 more
After many hours of unsuccessful trying, I found a workaround.
Code: [Select]
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
VGA1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080_60.00 59.98
   1920x1080     59.96*+
   1024x768      60.00 
   800x600       60.32    56.25 
   848x480       60.00 
   640x480       59.94 
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Notice the two 1080 resolutions? Well, apparently that got (minecraft or lwjgl, not sure) confused, so the game couldn't find a monitor.

I corrected xorg.conf so to have a modeline named just "1920x1080", so it would replace the other mode who was causing the conflict.
Maybe if we look at the codebase we might find out what happened exactly?
« Last Edit: January 07, 2016, 19:32:52 by Piero512 »