Hello Guest

Minecraft No Sound (Windows 10)

  • 2 Replies
  • 6148 Views
Minecraft No Sound (Windows 10)
« on: January 24, 2015, 19:03:37 »
First off, I'm running Windows 10 Technical Preview (Should I report this to Microsoft too?), so I know it's a beta.

So, on the minecraft modpack Agrarian Skies v3.1.4 (or something like that. The latest version.), I open the game and have no sound. The sound mixer shows no Minecraft process. I tried reinstalling some lwjgl stuffs, and doing some weird workarounds I found on Google, but nothing works. Anyone know a solution?

Note: I reported this on the minecraft forums and I was told I may want to go here.

Error Report:

2015-01-24 12:53:11 [INFO] [STDOUT]
2015-01-24 12:53:11 [INFO] [STDOUT] Starting up SoundSystem...
2015-01-24 12:53:11 [INFO] [gendustry] Resouece manager reload, new language: en_US
2015-01-24 12:53:11 [INFO] [STDOUT] Initializing LWJGL OpenAL
2015-01-24 12:53:11 [INFO] [STDOUT] (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org)
AL lib: (EE) DoReset: Failed to initialize audio client: 0x88890010
2015-01-24 12:53:11 [INFO] [STDERR] Exception in thread "Thread-79" org.lwjgl.openal.OpenALException: Invalid Device
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.Util.checkALCError(Util.java:55)
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.ALC10.alcCreateContext(ALC10.java:251)
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.AL.init(AL.java:168)
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.AL.create(AL.java:138)
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.AL.create(AL.java:102)
2015-01-24 12:53:11 [INFO] [STDERR] at org.lwjgl.openal.AL.create(AL.java:201)
2015-01-24 12:53:11 [INFO] [STDERR] at paulscode.sound.libraries.LibraryLWJGLOpenAL.init(LibraryLWJGLOpenAL.java:164)
2015-01-24 12:53:11 [INFO] [STDERR] at paulscode.sound.SoundSystem.CommandNewLibrary(SoundSystem.java:1576)
2015-01-24 12:53:11 [INFO] [STDERR] at paulscode.sound.SoundSystem.CommandQueue(SoundSystem.java:2572)
2015-01-24 12:53:11 [INFO] [STDERR] at paulscode.sound.CommandThread.run(CommandThread.java:121)
2015-01-24 12:53:51 [INFO] [STDOUT] ERROR MESSAGE:
2015-01-24 12:53:51 [INFO] [STDOUT] SoundSystem did not load after 30 seconds.
2015-01-24 12:53:51 [INFO] [STDOUT]
2015-01-24 12:53:51 [INFO] [STDOUT] Starting up SoundSystem...
2015-01-24 12:53:52 [INFO] [STDOUT] Switching to No Sound
2015-01-24 12:53:52 [INFO] [STDOUT] (Silent Mode)
2015-01-24 12:53:52 [INFO] [STDOUT]

*

Offline abcdef

  • ****
  • 320
Re: Minecraft No Sound (Windows 10)
« Reply #1 on: January 25, 2015, 07:53:54 »
The error itself is saying it can't initialise the sound device (no audio device is enabled). With windows 10 beta being so new it could be a few things (with the no 1 most likely answer being "you are using windows 10 beta"). LWJGL uses OpenAL bindings, which means it isn't implementing much itself. If you aren't hearing anything then the openal binary DLL is probably not compatible with windows 10

If you are tech savy then try compiling openal on windows 10 and swapping it in to the minecraft package with your own.

I think you might need to wait this out a bit though and let Microsoft resolve the issues as they own both Windows 10 and minecraft. If their dev's have any LWJGL specific issues they can post here.

Re: Minecraft No Sound (Windows 10)
« Reply #2 on: January 25, 2015, 14:09:47 »
Ok, thanks for the response at least. I'll just wait it out. I'm tech savvy in different ways maybe ^^ I also did report it to Microsoft so they would know. Don't know why I didn't think of that, because as you said, they own Windows 10 and Minecraft.