Hello Guest

[BUG] glfwInit() broken

  • 3 Replies
  • 2907 Views
[BUG] glfwInit() broken
« on: January 20, 2015, 20:05:48 »
Hello everyone,
I recently ran some tests on a freshly setup Ubuntu installation and noticed that calling glfwInit() would simply not work. When called, the program seems to enter an infinite loop; neither are error messages thrown nor does anything happen. It seems that this bug exists in certain versions of GLFW (taken from http://stackoverflow.com/questions/1610458/glfw-window-fails-to-open-ubuntu). It would be nice if someone could investigate this.

For reference purposes, this are my system specs (I know, it's not quite a powerhouse :D):
Processor                   2x Intel(R) Pentium(R) CPU B960 @ 2.20GHz
Memory                     3897MB
Operating System        Ubuntu 14.10
Graphics Card             IntelHD 3000
« Last Edit: January 20, 2015, 20:07:26 by Bobthepeanut »

*

Offline spasi

  • *****
  • 2123
    • WebHotelier
Re: [BUG] glfwInit() broken
« Reply #1 on: January 20, 2015, 20:47:16 »
The only known issue with Ubuntu is this one. But that happens on glfwCreateWindow, not glfwInit. Also, the stackoverflow question you linked was asked 5 years ago, with a very old version of GLFW.

Have you set up an error callback before calling glfwInit?

*

Offline abcdef

  • ****
  • 320
Re: [BUG] glfwInit() broken
« Reply #2 on: January 21, 2015, 06:25:21 »
I am using Mint and it works perfectly fine

Are you sure you have opengl drivers installed? (sudo apt-get install build-essential;sudo apt-get install freeglut3-dev)

Re: [BUG] glfwInit() broken
« Reply #3 on: January 21, 2015, 16:46:22 »
I made a debugging mistake, indeed. Actually, the call to glfwCreateWindow() is broken. I'm sorry about the wrong information I gave.

Yes, an error callback is already setup.

Concerning drivers, I ran both of the commands you said, however, it didn't change anything.

In a nutshell, it seems to be https://github.com/LWJGL/lwjgl3/issues/35.

Sorry for the trouble.