Hello Guest

[BUG] Full-screen is offset in Gnome 3.14

  • 1 Replies
  • 2322 Views
[BUG] Full-screen is offset in Gnome 3.14
« on: November 11, 2014, 20:53:04 »
I've just recently updated to Gnome 3.14 and openSUSE 13.2 from Gnome 3.12 on openSUSE 13.1 (using an additional repository). I play a game called Revenge of the Titans, which appears to use LWJGL. Since the upgrade, running the game in full-screen results in it being positioned about 100px down and 100px to the right, so I can see a strip of the top and left of my desktop and I lose the bottom and right of my game.

I've also tried the fullscreen demo (http://www.lwjgl.org/webstart/demo.php/test.opengl.FullScreenWindowedTest) and that also exhibits the same behaviour. I've attached a screenshot.

System info:
 * openSUSE 13.2
 * Gnome 3.14
 * Java 1.7.0 (java-1_7_0-openjdk-1.7.0.71-1.1.x86_64)
 * Firefox 33
 * nVidia GeForce GT630 running proprietary drivers 340.58 (from the openSUSE repo, hosted by nVidia)

Other games using other libraries go straight to fullscreen correctly (Bastion, Snapshot, Aquaria, Cogs). Revenge of the Titans even thinks it is going full-screen correctly, because it logs:
Code: [Select]
Set viewport to org.lwjgl.util.Rectangle[x=0,y=0,width=1920,height=1080]The whole screen briefly flashes, as if it tries to use the correct position, but then it ends up as in the screenshot.

This has only happened since upgrading to openSUSE 13.2, so I guess it is probably Gnome related.

Happy to provide more information if necessary.

Re: [BUG] Full-screen is offset in Gnome 3.14
« Reply #1 on: January 26, 2015, 19:54:13 »
I've just been trying this again. I'm still running the same Java, but a slightly newer version of the nVidia drivers (340.65). I've even tried dropping the latest lwjgl JAR and .so files into my Revenge of the Titans directory, in case there has been a quiet fix, but I still get the same issue.

Unfortunately, the webstart demo seems to be gone now and its new location (http://legacy.lwjgl.org/…) breaks with an error about being unable to parse the JNPL file.

Has no-one else experienced this problem?

Thanks.