Hello Guest

OSX Mavericks and OpenGL 3.3

  • 2 Replies
  • 4943 Views
OSX Mavericks and OpenGL 3.3
« on: February 23, 2014, 07:44:43 »
Just a note for other mac users trying to get a core opengl context for version 3.3, when you ask for a core profile with 3 as the majorVersion and 3 as the minorVersion (when you call Display.create), you're returned a 2.1 context... BUT when you ask for a 3.2 context you're given a 4.1 context.

So, even though my shader uses #version 330, I need to request 3.2 for it to work.

*

Offline ra4king

  • **
  • 58
  • I'm the King!
    • Roi's Website
Re: OSX Mavericks and OpenGL 3.3
« Reply #1 on: February 23, 2014, 08:26:34 »
This should be marked as a bug for LWJGL to fix, as LWJGL should be using NSOpenGLProfileVersion3_2Core when 3.2+ is requested.
-Roi

*

Offline spasi

  • *****
  • 2052
    • WebHotelier
Re: OSX Mavericks and OpenGL 3.3
« Reply #2 on: May 02, 2014, 20:14:20 »
Sorry for taking so long to fix this. Please see this post.