Hello Guest

OpenGL version issues

  • 2 Replies
  • 1821 Views
*

Offline abcdef

  • ****
  • 320
OpenGL version issues
« on: February 01, 2014, 12:45:02 »
Hi

I am having some issues on OpenGL versions on my mac, it should support version 3.3 according to apple. I have an old Mac Book with a 9400 in running the latest os version.

When I run (from lwjgl) GL11.glGetString(GL11.GL_VERSION), I get

2.1 NVIDIA-8.18.28 310.40.05f01

When I run glxinfo I get

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: NVIDIA GeForce 9400M OpenGL Engine
OpenGL version string: 2.1 NVIDIA-8.18.28 310.40.05f01
OpenGL shading language version string: 1.20

But

Apple says I should have 3.3

https://developer.apple.com/graphicsimaging/opengl/capabilities/index.html

and this native application say I do too.

https://itunes.apple.com/us/app/opengl-extensions-viewer/id444052073?mt=12&ign-mpt=uo%3D4

I've seen somewhere that glxinfo uses the X11 api and that this doesn't use the native supported libraries.

Has anyone seen this too and know of anyway to get 3.3 supported in lwjgl (as it should be available)?

Thanks

abcdef

*

Offline spasi

  • *****
  • 2132
    • WebHotelier
Re: OpenGL version issues
« Reply #1 on: February 01, 2014, 14:05:12 »
On MacOS, you need to be explicit about what OpenGL version you require, using the ContextAttribs API.

*

Offline abcdef

  • ****
  • 320
Re: OpenGL version issues
« Reply #2 on: February 01, 2014, 15:00:52 »
Thanks that worked, I take it with this I now set the minimum opengl version to 3.2. Time to convert the rest of my code to opengl 3+ now :)