Hello Guest

[SOLVED]Fullscreen problems on Linux

  • 4 Replies
  • 7753 Views
[SOLVED]Fullscreen problems on Linux
« on: August 13, 2013, 12:25:16 »
I'm not quite sure if I should post this here or in the bugs forum, but I suppose this is the rigth place, because this isn't necessarily a bug.

On my Linux x64 System I have problems with fullscreen. They first started with Minecraft, so I went investigating and tried the SpaceInvanders game, which worked fine.
But then I tested the WindowCreationTest, and it failed simillary at fullscreen(both with the normal and the shift-F way).

What happens is that the graphics get all random(see the video) and it's impossible to get gnome to respond. The only way I have found to fix this is to go into another tty and restart gdm.
normally that wouldn't work either because the primary monitor is just gone black. but because I have two, I could rescue the system with the other one. The other monitor is disabled by LWJGL when it goes to fullscreen, btw.

I used jstack to get a stack dump from the WindowCreationTest process and this is the result:
Fullscreen launched with shift-F :
befor I try to kill the process: http://sprunge.us/PbDR
after I have tried to kill it: http://sprunge.us/LjZV
Fullscreen launched normally, with F:
before I try to kill the process: http://sprunge.us/LQMB
after I have tried to kill it: http://sprunge.us/DSii

As said my system is Linux x64. It's running Archlinux with Gnome as the Window manager.
My video card is an AMD Radeon HD 6700 and the driver is the propitary Catalyst driver(13.101).

The video: http://www.youtube.com/watch?v=JDWSosOv3Jo

I hope someone knows why this is happening and a possible way to fix it.
« Last Edit: August 23, 2013, 14:52:32 by totokaka »

Re: Fullscreen problems on Linux
« Reply #1 on: August 13, 2013, 15:44:39 »
As a long time linux lwjgl user i will give my 2c. First of all you need the right mode lines in your xorg.config or whatever its called these days when you have dual monitors. This often fixes issues including video ram corruption or at least has in the past for me.

The next and perhaps less helpful issue is driver bugs. There are many and the AMD have a much larger list of issues i am afraid. Update the driver/downgrade the driver *may* help. But it may not. There is really not much you can do but try a few of a the available drivers in this case. Do other opengl apps work in fullscreen?

Case in point, even the latest Nvidia drivers on my work machine, video acceleration randomly turns off after about 3 days. While my laptop at home is at something like 30 days of uptime with no problems. 

It should also be noted that this can be an issue even on windows/macs. I would always provide a "windowed" version of a game/app because it does provide a much more reliable fall back.

However if you feel/show the problem is with lwjgl, then I would post a bug report.
If you want a plot read a book and leave Hollywood out of it.

Re: Fullscreen problems on Linux
« Reply #2 on: August 13, 2013, 17:45:26 »
Thanks for the answer. Do you know where I can find some resources on this? and maybe a free OpenGL game that supports fullscreen, so I can test?
Minecraft works in fullscreen sometimes btw. and SpaceInvaders did.

Re: Fullscreen problems on Linux
« Reply #3 on: August 14, 2013, 13:36:55 »
Tux racer? Otherwise Blender will put the driver through its paces and supports a FS mode IIRC. mplayer and vlc have gl drivers that won't test it much, but at least a little. ioquake is free, but you need legal copies of the pak files from the game, perhaps the demo would work. 
If you want a plot read a book and leave Hollywood out of it.

Re: Fullscreen problems on Linux
« Reply #4 on: August 23, 2013, 14:52:16 »
Crossposting the LWJGL forums thread and the Minecraft bug report

On my system this is working. I did an upgrade of the drivers, and I updated to Xorg 1.14. I can't say excately what fixed it but it's now working. As long as I disable the secound monitor first, anyways.