Hello Guest

[FIXED] HelloOpenCL crashes JVM running NativeKernel on AMD CPU device

  • 4 Replies
  • 3587 Views
Using lwjgl 2.8.3, HelloOpenCL crashes the JVM right when it starts running the native kernel.
The other platform / device on this system (nVidia GPU) never performs the native kernel parts because it doesn't pass the CL_EXEC_NATIVE_KERNEL caps check on line 142, so I can't say if this is an AMD / CPU specific problem.
I'm on Windows 7 64-bit.

Here's the full output of HelloOpenCL, showing the device info and extensions:

-------------------------
NEW PLATFORM: 8791469115848
OpenCL 1.1 - Extensions: cl_khr_d3d10_sharing cl_khr_icd
-------------------------
   CL_PLATFORM_PROFILE = FULL_PROFILE
   CL_PLATFORM_VERSION = OpenCL 1.1 AMD-APP (831.4)
   CL_PLATFORM_NAME = AMD Accelerated Parallel Processing
   CL_PLATFORM_VENDOR = Advanced Micro Devices, Inc.
   CL_PLATFORM_EXTENSIONS = cl_khr_icd cl_amd_event_callback cl_amd_offline_devices cl_khr_d3d10_sharing


   NEW DEVICE: 127750016
OpenCL 1.1 - Extensions: cl_amd_device_attribute_query cl_amd_fp64 cl_amd_media_ops cl_amd_popcnt cl_amd_printf cl_amd_vec3 cl_ext_device_fission cl_khr_byte_addressable_store cl_khr_fp64 cl_khr_gl_sharing cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics
   -------------------------
   CL_DEVICE_TYPE = 2
   CL_DEVICE_VENDOR_ID = 4098
   CL_DEVICE_MAX_COMPUTE_UNITS = 6
   CL_DEVICE_MAX_WORK_ITEM_DIMENSIONS = 3
   CL_DEVICE_MAX_WORK_GROUP_SIZE = 1024
   CL_DEVICE_MAX_CLOCK_FREQUENCY = 3600
   CL_DEVICE_ADDRESS_BITS = 64
   CL_DEVICE_AVAILABLE = true
   CL_DEVICE_COMPILER_AVAILABLE = true
   CL_DEVICE_NAME = AMD Phenom(tm) II X6 1090T Processor
   CL_DEVICE_VENDOR = AuthenticAMD
   CL_DRIVER_VERSION = 2.0
   CL_DEVICE_PROFILE = FULL_PROFILE
   CL_DEVICE_VERSION = OpenCL 1.1 AMD-APP (831.4)
   CL_DEVICE_EXTENSIONS = cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extended_atomics cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_device_fission cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing
   CL_DEVICE_OPENCL_C_VERSION = OpenCL C 1.1
-TRYING TO EXEC NATIVE KERNEL-
NATIVE KERNEL STATUS: CL_QUEUED
NATIVE KERNEL STATUS: CL_SUBMITTED
NATIVE KERNEL STATUS: CL_RUNNING

...And BAM! JVM crash followed my Microsoft wanting me to report the problem.
« Last Edit: February 28, 2012, 20:01:11 by kappa »

*

Offline Matzon

  • *****
  • 2242
Re: [BUG] HelloOpenCL crashes JVM running NativeKernel on AMD CPU device
« Reply #1 on: February 28, 2012, 15:31:54 »
try updating drivers - it's typically not a lwjgl bug..

Re: [BUG] HelloOpenCL crashes JVM running NativeKernel on AMD CPU device
« Reply #2 on: February 28, 2012, 15:35:04 »
After I posted this, I decided to write a little C program to duplicate HelloOpenCL without lwjgl and test directly.
Feel free to ignore this post until I report back. 
If it still crashes, I'll just move my bug report to AMD's forums :)

Re: the reply posted while I was typing this.  TY, I'll check on that before I assert that all my drivers are up to date.

*

Offline spasi

  • *****
  • 2163
    • WebHotelier
Re: [BUG] HelloOpenCL crashes JVM running NativeKernel on AMD CPU device
« Reply #3 on: February 28, 2012, 16:27:24 »
This happens for me too, on x64 only. I'll look into it and let you know asap.

*

Offline spasi

  • *****
  • 2163
    • WebHotelier
Re: [BUG] HelloOpenCL crashes JVM running NativeKernel on AMD CPU device
« Reply #4 on: February 28, 2012, 18:19:00 »
Thanks rpmfl72, it should be fixed with the next nightly build.