Hello Guest

"invalid drawable" message on OSX

  • 3 Replies
  • 11729 Views
*

Offline ac

  • *
  • 8
"invalid drawable" message on OSX
« on: February 23, 2012, 15:30:08 »
Hello,

I'm trying out the integration between AWT Applet and LWJGL. I followed some of the examples posted on the wiki, and managed to write my own basic applet that uses a LWJGL Display to handle OpenGL rendering. Everything works fine, with the exception of two minor quirks:

1) When I start the applet, I get a message "Make pbuffer: 300 x 300" in the console. It seems like a initialization notification. Is it possible to suppress it?

2) Also when I start the applet, and for only one time, I get an "invalid drawable" message. It seems that something went wrong when initializing the canvas or the display, however it doesn't appear to have any effect. But still makes me think that I'm doing something incorrectly in the setup.

These two messages only appear when I run the applet on Mac OSX (tested both on Snow Leopard and Lion using LWJGL 2.8.3). The code for the full application is here: http://pastebin.com/FWaiDz2v

Any feedback will be appreciated.

Thanks!

*

Offline kappa

  • *****
  • 1314
Re: "invalid drawable" message on OSX
« Reply #1 on: February 23, 2012, 15:58:35 »
1) On OS X internally a pbuffer is required for applets to function. That "Make pbuffer" message is just something LWJGL throws out to inform you of how large the pbuffer is. Its harmless really, but if its really annoying then it can be commented out in the LWJGL code.

2) This is an issue with Apple's java plugin, for whatever reason it always throws that message, again seems to have no effect. Not really a LWJGL issue.

*

Offline ac

  • *
  • 8
Re: "invalid drawable" message on OSX
« Reply #2 on: February 25, 2012, 00:16:47 »
Thanks for the quick and concise answer.

The pbuffer message is not a big issue at this point. If later I want remove, what is the best way to make a feature request like that? Through the sourceforge page of the project?

*

Offline kappa

  • *****
  • 1314
Re: "invalid drawable" message on OSX
« Reply #3 on: February 25, 2012, 00:41:03 »
raise an RFE on this forums BUG/RFE section.