Hello Guest

[CLOSED] UnsatisfiedLinkError: org.lwjgl.opengl.GLContext.getFunctionAddress

  • 2 Replies
  • 5383 Views
Hi,
I have started using LWJGL and while running a test app in eclipse environment on Windows7, I am getting:

java.lang.UnsatisfiedLinkError: org.lwjgl.opengl.GLContext.getFunctionAddress(Ljava/lang/String;)J
   at org.lwjgl.opengl.GLContext.getFunctionAddress(Native Method)
   at org.lwjgl.opengl.ContextCapabilities.initAllStubs(ContextCapabilities.java:4678)
   at org.lwjgl.opengl.ContextCapabilities.<init>(ContextCapabilities.java:5014)
   at org.lwjgl.opengl.GLContext.useContext(GLContext.java:349)
   at org.lwjgl.opengl.Context.makeCurrent(Context.java:194)
   at org.lwjgl.opengl.AbstractDrawable.makeCurrent(AbstractDrawable.java:44)
   at org.lwjgl.opengl.Display.makeCurrent(Display.java:732)
   at org.lwjgl.opengl.Display.makeCurrentAndSetSwapInterval(Display.java:897)
   at org.lwjgl.opengl.Display.create(Display.java:861)
   at org.lwjgl.opengl.Display.create(Display.java:785)
   at test.SimpleTest.createDisplay(SimpleTest.java:138)
   at test.SimpleTest.run(SimpleTest.java:306)
   at test.SimpleTest.main(SimpleTest.java:86)

Earlier, I was getting lwjgl not found in library path but that was solved by specifying native library attribut for lwjgl.jar.

« Last Edit: November 28, 2011, 03:27:39 by adm_aj »

*

Offline Matzon

  • *****
  • 2242
since this error would imply that lwjgl wouldn't work for anyone, I am leaning towards something specific to your environment.

Have you done the usual tests, like testing that you have up to date OpenGL drivers, LWJGL binaries and confirmed that the OpenGL tests supplied in org.lwjgl.test.* also fail? Does it work from command line

Thanks for the reply.
The problem was coming because TWL GUI Library was using an incorrect version of lwjgl.jar
But the problem was specifically coming in LWJGL, so I didn't initially think that as a possibility.
Replacing with latest version from LWJGL solved the problem.