Hello Guest

[CLOSED] Scala project won't compile

  • 2 Replies
  • 3325 Views
[CLOSED] Scala project won't compile
« on: October 15, 2011, 01:19:27 »
I just downloaded lwjgl-2.8.0, and tried incorporating it into my project; but the Scala compiler really doesn't like something about "org.lwjgl.opengles.PixelFormat$Attrib".  This problem is popping up in both SBT (simple build tool) and Eclipse.  I'm using Scala 2.9.1 and lwjgl-2.7.1 worked just fine with all of my Scala projects in the past.

Here is the error I'm getting:

[info] Compiling 2 Scala sources to ...../backends/lwjgl/target/scala-2.9.1.final/classes...
[error] backend-lwjgl/compile: java.lang.AssertionError: org.lwjgl.opengles.PixelFormat$Attrib
[error] Total time: 3 s, completed Oct 14, 2011 9:09:23 PM

Any help would be much appreciated.

Thanks.
« Last Edit: October 15, 2011, 13:58:56 by kappa »

*

Offline kappa

  • *****
  • 1314
Re: [BUG] Scala project won't compile
« Reply #1 on: October 15, 2011, 06:32:04 »
This is a bug that has already been fixed, please try the nightly builds of LWJGL. The next release LWJGL 2.8.1 will be out shortly.

Re: [CLOSED] Scala project won't compile
« Reply #2 on: October 16, 2011, 03:08:54 »
lol.  I thought that I had searched pretty hard before posting that.  Next time I'll make sure to check out the Resolved thread as well.

Thanks.