Hello Guest

[FIXED] Unicode input

  • 19 Replies
  • 22149 Views
Re: [FIXED] Unicode input
« Reply #15 on: August 22, 2011, 11:20:48 »
That fix seem to broke stuff for me. I got SIGSEGV on the latest nightly bulid, what I didn't got in rev 3307. Here is the error log: http://pastebin.com/5HdfQx9H

*

Offline spasi

  • *****
  • 2211
    • WebHotelier
Re: [FIXED] Unicode input
« Reply #16 on: August 22, 2011, 14:02:40 »
The java.lang.String.getBytes() in the log looks suspicious. It shouldn't be there, getBytes isn't called with the recent changes. Are you absolutely sure you're using the latest binaries?

*

Offline kulpa

  • *
  • 11
Re: [FIXED] Unicode input
« Reply #17 on: August 22, 2011, 14:49:03 »
Yesterday I observed the same issue with the svn version.
I get it, when I omit setting the `java.library.path` property.
(with it everything works fine, so not a big deal)

http://pastebin.com/cE0Scdv4

*

Offline Matzon

  • *****
  • 2242
Re: [FIXED] Unicode input
« Reply #18 on: August 22, 2011, 15:26:59 »
bump native version id ?

Re: [FIXED] Unicode input
« Reply #19 on: October 01, 2011, 10:56:39 »
OMG! this was actually fixed. I didn't know, I adventured into JOGL and found it lacking. Then tried Eclipse SWT, which has a weird problem where keyboard presses don't go up for some reason, till now, nobody has responded to the SWT thread (here: http://www.eclipse.org/forums/index.php/t/239408/).

THANK YOU SO MUCH!!!!!!
« Last Edit: October 01, 2011, 10:58:54 by fellowusertoo »