Hello Guest

[CLOSED] No sound in Minecraft

  • 1 Replies
  • 8540 Views
[CLOSED] No sound in Minecraft
« on: September 25, 2011, 18:03:18 »
After I tried OpenJDK 7 on Ubuntu 64 Bit I got the error about a wrong ELFCLASS32 (OpenJDK 6 is working fine). This happened on the distributed version of LWJGL in Minecraft (a version before 2.7.1 but I can't say exactly which) and on version 2.7.1. So I tried a build of version 2.8.0 (#1349) but the sound doesn't load anymore. I get this output:

Quote
Starting up SoundSystem...
Initializing LWJGL OpenAL
    (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
Exception in thread "Thread-9" java.lang.UnsatisfiedLinkError: org.lwjgl.openal.AL10.initNativeStubs()V
   at org.lwjgl.openal.AL10.initNativeStubs(Native Method)
   at org.lwjgl.openal.AL.init(AL.java:156)
   at org.lwjgl.openal.AL.create(AL.java:138)
   at org.lwjgl.openal.AL.create(AL.java:102)
   at org.lwjgl.openal.AL.create(AL.java:201)
   at paulscode.sound.libraries.LibraryLWJGLOpenAL.init(SourceFile:162)
   at paulscode.sound.SoundSystem.CommandNewLibrary(SourceFile:1489)
   at paulscode.sound.SoundSystem.CommandQueue(SourceFile:2362)
   at paulscode.sound.CommandThread.run(SourceFile:121)
    ERROR MESSAGE:
        SoundSystem did not load after 30 seconds.

Starting up SoundSystem...
Switching to No Sound
    (Silent Mode)

But I don't know if this is an incompatibility of Minecraft with LWJGL 2.8.0 or a bug in LWJGL 2.8.0.
« Last Edit: September 25, 2011, 18:05:31 by Sworddragon »

*

Offline kappa

  • *****
  • 1316
Re: [BUG] No sound in Minecraft
« Reply #1 on: September 25, 2011, 20:41:33 »
this is a known bug with the current LWJGL nightly builds, see this thread.