Hello Guest

JCreator LE issues

  • 16 Replies
  • 22028 Views
*

Offline kappa

  • *****
  • 1316
Re: JCreator LE issues
« Reply #15 on: January 05, 2011, 14:12:39 »
with eclipse you shouldn't need to compile any thing manually, you just write the code, click save and hit the run button.

As for your JCreator IDE (i don't use it so maybe a little off) but you've got to make sure the Runtime Configuration is set correctly, there must be something like setting 'Run Application', try right clicking the mian class to see if there some option to change it.

Re: JCreator LE issues
« Reply #16 on: January 05, 2011, 14:34:55 »
I did find this http://www.jcreator.com/forums/index.php?showtopic=7100&pid=21894&mode=threaded&start=#entry21894thread on the topic that talks about that and I still have no idea why I get this "command" class problem, but I did make a class called command and then I got this error (its with jinpur.jar included)

--------------------Configuration: Main - JDK version 1.6.0_16 new tool - <Default>--------------------
Keys:
down  - Shrink
up    - Grow
left  - Rotate left
right - Rotate right
esc   - Exit
Exception in thread "main" java.lang.NoClassDefFoundError: org/lwjgl/input/Mouse
   at command.destroy(command.java:88)
   at command.main(command.java:55)
Caused by: java.lang.ClassNotFoundException: org.lwjgl.input.Mouse
   at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
   at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
   ... 2 more

Process completed.


EDIT:: I got the netbeans example to work so I'm happy for now, but thanks for at least trying.
« Last Edit: January 05, 2011, 16:24:15 by verthex »