Hello Guest

[SOLVED] Security error with Applet

  • 17 Replies
  • 12664 Views
Re: Security error with Applet
« Reply #15 on: May 19, 2009, 14:13:36 »
That works indeed, weird stuff.

I added permission java.security.AllPermission; in my java.security file and that also worked around the problem.

A senior Java developer that just walked past my desk and looked at the code of the AppletLoader thought that it might be because of the usage of:
Class.forName(getParameter("al_main"));
he recommended to instead use:
Thread.currentThread().getContextClassLoader().loadClass(getParameter("al_main"));

Don't ask me though because I am not that familiar with the inner workings of Java but it might be an idea :)

*

Offline kappa

  • *****
  • 1316
Re: Security error with Applet
« Reply #16 on: May 22, 2009, 09:20:05 »
The bug has now been fixed (was a damn ugly issue :)), you should be able to connect to your host as normal.

This should be available in LWJGL 2.2.0 (or whatever the next release is called), should be out soon.

Alternatively if you need updated AppletLoader urgently, you can checkout the code from svn or if you or pop into the #LWJGL irc channel on freenode.net someone will point you to the nightly builds.

Re: Security error with Applet
« Reply #17 on: May 22, 2009, 09:40:09 »
Perfect, thanks :) I see in the SVN that my friend was on the right track but he missed the PermissionCollection.

I'll await 2.2 seeing as the workaround works fine for now.
« Last Edit: May 22, 2009, 10:02:21 by Mickelukas »