Hello Guest

X Error - disp: 0x864fa50 serial: 38 error: BadMatch (invalid param.....)

  • 2 Replies
Hi, when I try to run WindowCreationTest I get the following error:

Code: [Select]
The following keys are available:
ESCAPE:                Exit test
ARROW Keys:        Move window when in non-fullscreen mode
L:                List selectable display modes
0-8:                Selection of display modes
F:                Toggle fullscreen
SHIFT-F:        Toggle fullscreen with Display.destroy()/create() cycle
Found 14 display modes
Problem retrieving mode with 640x480x16@-1
Problem retrieving mode with 640x480x32@-1
Problem retrieving mode with 800x600x16@-1
Problem retrieving mode with 800x600x32@-1
Problem retrieving mode with 1024x768x16@-1
Problem retrieving mode with 1024x768x32@-1
org.lwjgl.LWJGLException: X Error - disp: 0x864fa50 serial: 38 error: BadMatch (invalid parameter attributes) request_code: 1 minor_code: 0
        at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:284)
        at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)
        at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:429)
        at org.lwjgl.opengl.Display.createWindow(Display.java:308)
        at org.lwjgl.opengl.Display.create(Display.java:839)
        at org.lwjgl.opengl.Display.create(Display.java:767)
        at org.lwjgl.opengl.Display.create(Display.java:748)
        at org.lwjgl.test.WindowCreationTest.initialize(WindowCreationTest.java:92)
        at org.lwjgl.test.WindowCreationTest.main(WindowCreationTest.java:284)

I'm on ubuntu 9.04 with Java(TM) SE Runtime Environment (build 1.6.0_13-b03) and I cannot make it run on my T41p with FireGL T2 using the radeon driver, it used to work some time ago. On my other system, also with up-to-date ubuntu 9.04 and an nVidia graphics card it works without problems.
I read the post where it was said that jMonkeyEngine is to blame with it (and yes I'm having jME issues too with the same error) but this does not explain why this test program throws the above exception.

Anybody has any idea what might be wrong in here?!



Offline elias

  • *****
  • 899
    • http://oddlabs.com
This might have been fixed already. Please try a nightly build from:


and see if the error is still there.

 - elias


Offline mot

  • **
  • 57
    • http://www.catnapgames.com
Found this error via Google - I was getting the exact same one. The nightly build worked. Still not a win since the particular Ubuntu install had no proper 3D acceleration but this error went away in the nightly build, yes - confirmed.
Tom Andrle - Catnap Games - http://www.catnapgames.com