A little correction on http://lwjgl.org/installation.php

Started by monn, August 23, 2006, 10:10:36

Previous topic - Next topic


Hi, this is what I've found in http://lwjgl.org/installation.php :

Test LWJGL by opening a command prompt, and navigating to the folder where the archive was extracted. Once navigated, issue the following command:

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native org.lwjgl.test.WindowCreationTest

I (like some other users) found UnsatisfiedLinkError when issuing above command. It should be

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native/win32 org.lwjgl.test.WindowCreationTest

on Windows, or

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native/linux org.lwjgl.test.WindowCreationTest

on Linux, or

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native/macosx org.lwjgl.test.WindowCreationTest

on OSX.

Thank you.
eautiful lines of code aren't not written, they are debugged.


You are right, there is something definitely wrong with their installation part. Once I tried yours I immediately got a Java window..

Thanks! :wink:


the installation page was updated some time ago, following the original post - so you should have been able to use the installation page?


I tried this code and I am getting an error message >:(.  I cut and pasted it into the cmd window.

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native/win32 org.lwjgl.test.WindowCreationTest

This is the error I get

Exception in thread "main" java.lang.NoClassDefFoundError: org/lwjgl/test/WindowCreationTest

I'm running windows Vista, just installed Java updates, OpenGl, and I have the latest drivers for my video card
Graphics Media Accelerator 900.

I'm going back and trying version 1.2 to see if that will make a difference.  Also, I lumped everything together in one folder the first time I extracted everything.  This time I am putting everything into sub-folders with the appropriate names as per the zip file ext's.  Hopefully this will make the difference  ::)


seems to work fine here...

QuoteC:\lwjgl-1.1.3>java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar; -Djava.library.path=native/win32 org.lwjgl.test.WindowCreationTest
The following keys are available:
ESCAPE:         Exit test
ARROW Keys:     Move window when in non-fullscreen mode
L:              List selectable display modes
0-8:            Selection of display modes
F:              Toggle fullscreen
SHIFT-F:        Toggle fullscreen with Display.destroy()/create() cycle
Found 30 display modes
Problem retrieving mode with 640x480x24@-1
Problem retrieving mode with 800x600x24@-1
Problem retrieving mode with 1024x768x24@-1


here is an additional suggestion for the installation.php file part for macs

when i copied and pasted

java -cp .;res;jar\lwjgl.jar;jar\lwjgl_test.jar;jar\lwjgl_util.jar;jar\lwjgl_fmod3.jar;jar\lwjgl_devil.jar;jar\jinput.jar;      -Djava.library.path=native/macosx org.lwjgl.test.WindowCreationTest

into the terminal. i get

-bash: -Djava.library.path=native/macosx: No such file or directory

it appears that a carriage return is present in front of -Djava... copying the command from the page into a text editor first, removing the new line in front of -Djava, then copying that into the terminal finally works. it would make life a lot easier for newbies like me, if that new line would be removed from the page. ciao,