LWJGL

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2

Author Topic: LWJGL 1.1.3 Released  (Read 21056 times)

Matzon

  • Administrator
  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
LWJGL 1.1.3 Released
« on: October 30, 2007, 22:15:42 »

LWJGL 1.1.3 released

Download
Release notes

* AppletLoader: miscellaneous minor fixes to improve the loading and displaying of the applet. Also fixes Opera issues, please use latest Opera. Thanks KappaOne.
* Make sure that any windows cursor image pixel is either 0xffxxxxxx or 0x00000000
* Miscellaneous GL updates to match spec
* Added KEY_LMETA and KEY_RMETA to Keyboard to replace the windows centric KEY_LWIN and KEY_RWIN, which are now deprecated
* Mac OS X: Mapped the option key to Keyboard.KEY_LWIN and Keyboard.KEY_RWIN instead of KEY_*META like the alt key
* Updated jinput.
* Miscellaneous bug fixes. Please check changelog.   

As always, consider donating if you use LWJGL.

kappa

  • Administrator
  • Nerdus Imperius
  • *****
  • Offline Offline
  • Posts: 1202
Re: LWJGL 1.1.3 Released
« Reply #1 on: October 31, 2007, 12:23:38 »

great work as always ppl, thx.
Logged

Jens v.P.

  • Regular nerd
  • **
  • Offline Offline
  • Posts: 50
Re: LWJGL 1.1.3 Released
« Reply #2 on: October 31, 2007, 13:02:33 »

I've updated the Eclipse plugin, too. It's available from the update site, for details, see http://lwjgl.org/forum/index.php/topic,2379.15.html . If you have already installed the plugin, you can simply use Eclipse's update mechanism.
Logged

Matzon

  • Administrator
  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Re: LWJGL 1.1.3 Released
« Reply #3 on: October 31, 2007, 13:36:05 »

* Matzon makes a mental note to integrate this into the release cycle
prob should be done with a new build file too  >:(

Fool Running

  • Nerdus Imperius
  • *****
  • Offline Offline
  • Posts: 828
Re: LWJGL 1.1.3 Released
« Reply #4 on: November 04, 2007, 21:53:34 »

Yeah, new release 8)
Keep up the good work guys. ;D
Logged
Programmers will, one day, rule the world... and the world won't notice until its too late.Just testing the marquee option ;D

numberR

  • Talks Too Much
  • ***
  • Offline Offline
  • Posts: 101
Re: LWJGL 1.1.3 Released
« Reply #5 on: November 09, 2007, 21:34:55 »

Great job, guys!
I just wanted to let you guys know that it worked great on Mac OS X 10.5 :)
Logged

rhk

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Re: LWJGL 1.1.3 Released
« Reply #6 on: November 26, 2007, 04:28:48 »

Is the source to the org.lwjgl.test plug-in for eclipse available some place?

I looked in the SVN archive for LWJGL, but the eclipse parts didn't seem to be there.
Logged

wolf_m

  • Regular nerd
  • **
  • Offline Offline
  • Posts: 86
Re: LWJGL 1.1.3 Released
« Reply #7 on: December 31, 2007, 04:44:55 »

I've upgraded half an hour ago and ran into some GLIBC-related issues; it seems you guys used libraries that are too new for Debian Etch when you compiled this version.

I just uploaded a self-compiled liblwjgl.so, version 1.1.3 for those unfortunate people who suffer from such outdated GLIBC's. I compiled it with Debian Etch.

So if your java complains about missing GLIBC_2.4 stuff when starting an application using lwjgl, use this one.

I didn't find this on the internet, thus uploaded it. Spares you the time of getting the lwjgl source and running ant.

Here's the link: Rapidshare
Logged

kburjack

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: LWJGL 1.1.3 Released
« Reply #8 on: January 07, 2008, 20:52:53 »

Hi folks,

we are starting to use lwjgl to write a simple game and appreciate your work very much in that it makes our work a lot easier. Especially to deal with multiple different platforms.

We used lwjgl 1.1.3 and under Windows and Mac OS X there are no problems at all.
But the Linux natives makes us a lot of troubles.

When lwjgl is being loaded, it says the jar version, which is 11, is not equal to the native's version, which is 7.

After investigating the lwjgl source code for both the java and the natives, we believe that the current binary version of lwjgl for linux has not been compiled using these sources.
The approriate lines in the org.lwjgl.Sys:

   /** Current version of the JNI library */
60:   static final int JNI_VERSION = 11;

103:   int native_jni_version = implementation.getJNIVersion();
104:   if (native_jni_version != JNI_VERSION)
105:      throw new LinkageError("Version mismatch: jar version is '" + JNI_VERSION +
106:                      "', native libary version is '" + native_jni_version + "'");

indicates that the java part of the JNI expects a version number of 11.

But the lines in the natives org_lwjgl_DefaultSysImplementation.h:

11:   #define org_lwjgl_DefaultSysImplementation_JNI_VERSION 11L

tells, that 11 is also the version number to be returned by the native getJNIVersion() JNI call at common_tools.c:61

This leads us to the initial assumption that the linux natives were NOT being compiled using the source code offered at sourceforge for the 1.1.3 of lwjgl.

(Hint: We can also exclude any side effects of other previous lwjgl natives being loaded before the 1.1.3 one)


We hope you can comment on this issue.
Logged

Matzon

  • Administrator
  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Re: LWJGL 1.1.3 Released
« Reply #9 on: January 07, 2008, 22:00:18 »

I am unable to confirm this. Works fine - except for the glibc 2.4 issue - tested in debian 32 & 64 bit + ubuntu 7.10

kburjack

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: LWJGL 1.1.3 Released
« Reply #10 on: January 07, 2008, 23:21:43 »

Hi.

Tanks for the quick answer!

The error is still there, but for some reason, the tests at "http://lwjgl.org/installation.php" work fine.....

Maybe this has something to do with the optional libraries in "lwjgl_optional-1.1.3", which we are also using, for e.g. texture loading and sounds?
Logged

Matzon

  • Administrator
  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Re: LWJGL 1.1.3 Released
« Reply #11 on: January 07, 2008, 23:57:04 »

well, not really - fmod and devil has never been at 7 in native version...
please check your javahome/jre/ext dir for old lwjgl files?

kburjack

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: LWJGL 1.1.3 Released
« Reply #12 on: January 08, 2008, 21:24:22 »

 :( Something is really weared here:

What I did was:
- Make a complete fresh install of Ubuntu 7.10 "Desktop" on a clean PC
- Run Ubuntu-Installation using the defaults
- Installing sun jdk 1.5.0 Update 13
- Then upgrading all installed packages using the package manager to the latest version so that there weren't any updates reported after that
- Installing other requirements: ant, subversion
- Downloading lwjgl 1.1.3 from sourceforge
- Running the project
---> Same version mismatch from org.lwjgl.Sys .......

This is driving me crazy...

Okay, but if you (Matzon) could not confirm this, maybe there is someone else here who can?

Now, I am starting to think that this might have something to do with the optional libraries being loaded before or after the liblwjgl.so and overwriting some functions or whatever.

We would really appreaciate any help on this!
Logged

kburjack

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: LWJGL 1.1.3 Released
« Reply #13 on: January 08, 2008, 21:41:13 »

Okay, now, I know that this issue is definitely being caused by the devil optional native.

When removing the devil library from the library path and commenting anything related to devil in our java source, the application runs without version mismatch errors. The liblwjgl.so have been loaded, else the application's main window would not have been visible, which it was.

I guess, that under linux, there must be some linking error when loading the natives...
Logged

Matzon

  • Administrator
  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Re: LWJGL 1.1.3 Released
« Reply #14 on: January 08, 2008, 21:42:38 »

hm, might be an issue related to sharing common_tools.c ... I'll investigate...
Pages: [1] 2