LWJGL Forum

Please login or register.

Login with username, password and session length
Pages: 1 [2]

Author Topic: Need SVN access  (Read 23174 times)

elias

  • Nerdus Imperius
  • *****
  • Offline Offline
  • Posts: 899
Re: Need SVN access
« Reply #15 on: August 25, 2007, 14:48:10 »

Sorry, forgot to put the build file in.  It is in there now.

Please check that it all compiles after an 'ant clean' before comitting to svn. I've comitted a few tweaks to build.xml and removed an import to get stuff running again.

 - elias

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Re: Need SVN access
« Reply #16 on: August 27, 2007, 21:02:52 »

As elias mentioned, please make sure that svn builds when you check in large pieces.
I added missing headers to build.xml and I added the missing dx9 libs to link against in windows_ant.

The DX stuff now compiles without any issues, however in order to run the tests, -Dorg.lwjgl.opengl.Display.noinput=true needs to be specified and all input creation disabled. This is because the code uses OpenGL stuff, and fails the creation test.
This should be fixed once the code is generified so that ogl and dx shares display and input (not at the same time ofcourse).

Are there any parts you are working on specifically right now CaptainJester?

CaptainJester

  • Talks Too Much
  • ***
  • Offline Offline
  • Posts: 175
Re: Need SVN access
« Reply #17 on: August 28, 2007, 12:46:30 »

I was first going to finish putting all the native code in the Direct3D interfaces, but haven't started yet.  So everything is fair game.
Logged
The problems of this world cannot possibly be solved by skeptics or cynics whose horizons are limited by the obvious realities.  We need men and women who can dream of things that never were. - John Fitzgerald Kennedy(35th US President)
8)
Pages: 1 [2]