LWJGL Forum

Please login or register.

Login with username, password and session length

Author Topic: Can't get fmod working on the Mac  (Read 13417 times)

Catfish

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Can't get fmod working on the Mac
« on: April 10, 2005, 11:51:11 »

Heya,
I'm having trouble persuading the fmod samples to work in OS X.

Code: [Select]

java -cp .:res:jar/lwjgl.jar:jar/lwjgl_test.jar:jar/lwjgl_util.jar:jar/lwjgl_fmod3.jar:jar/lwjgl_devil.jar: -Djava.library.path=native org.lwjgl.test.fmod3.DSPTest res/phero.mp3
Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl-fmod3 in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1517)
        at java.lang.Runtime.loadLibrary0(Runtime.java:788)
        at java.lang.System.loadLibrary(System.java:834)
        at org.lwjgl.fmod3.FMOD.initialize(FMOD.java:218)
        at org.lwjgl.fmod3.FMOD.<clinit>(FMOD.java:206)
        at org.lwjgl.test.fmod3.DSPTest.main(DSPTest.java:74)




I've been to the fmod site, and wasn't entirely sure which binaries I'm supposed to get...so I got both the NativeFmod Runtime and the FMod API packages.  I put the libraries from those in the native dir - is that right?


Any other hints would be appreciated.  I'm not a java programmer, so I'm feeling a little lost right here...
Logged

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Can't get fmod working on the Mac
« Reply #1 on: April 10, 2005, 13:46:40 »

fmod3 for lwjgl doesn not work at the moment, because fmod people didn't include a dynamic header for fmod on mac.

It's being worked on.

NativeFMod and FMOD4Java are 2 other implementations that are incompatible with lwjgl

Catfish

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Can't get fmod working on the Mac
« Reply #2 on: April 10, 2005, 13:50:41 »

Ah.  That would explain a lot...


Quote
It's being worked on.

Got any rough ETA?  Days/weeks/months?

Cheers,
Cat
Logged

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Can't get fmod working on the Mac
« Reply #3 on: April 11, 2005, 05:28:27 »

Sorry, no idea at all since I haven't looked at it yet. It looks rather simple, but being in this business for some time now, I know that looks can be deceiving ;)

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Can't get fmod working on the Mac
« Reply #4 on: April 12, 2005, 07:00:07 »

right, so people can't stop whining about it - so I took a look at it yesterday - and got it working!!
There are still some small kinks I need to work out (missing methods on mac (??) and some crashes). But basically it works as expected. I'll commit the build file later today (pending a talk with elias) and people should be able to build it themselves.

/matzon

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Can't get fmod working on the Mac
« Reply #5 on: April 12, 2005, 19:17:49 »

there - stuff comitted!

cd src/native/common/fmod3
export FMOD=path/to/fmod
make -f Makefile.macosx
... lots of warnings ...
compiled (hopefully)

copy liblwjgl-fmod3.jnilib to a folder and test

Callbacks are broken, and perhaps other stuff too. Will work on this, later this week.

Catfish

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Can't get fmod working on the Mac
« Reply #6 on: April 12, 2005, 20:42:26 »

Oooh, neat.  I'll give it a try - thanks. :)
Logged

Catfish

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Can't get fmod working on the Mac
« Reply #7 on: April 15, 2005, 10:05:27 »

Apologies if I'm missing something obvious, but shouldn't there be a org_lwjgl_fmod3_FMOD.h somewhere in there?

Cat
Logged

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
Can't get fmod working on the Mac
« Reply #8 on: April 15, 2005, 11:02:33 »

no, you need to build the headers by running:
ant headers

Catfish

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Can't get fmod working on the Mac
« Reply #9 on: April 15, 2005, 12:06:19 »

Ahhhh.  That's much easy than me generating the headers by going through the .c files & stripping out the definitions ;)


The lwjgl fmod samples seem to be working nicely now - thanks for all the help.
Logged