LWJGL Forum

Please login or register.

Login with username, password and session length

Author Topic: FSound_DSP_Create fails  (Read 8063 times)

WiESi

  • Regular nerd
  • **
  • Offline Offline
  • Posts: 70
FSound_DSP_Create fails
« on: January 15, 2006, 11:07:34 »

Hi!

I am using LWJGL 0.99 and Java 1.5 Update 5 and FMOD 3.75. I called
Code: [Select]
FMOD.create();
FSound.FSOUND_Init(44100, 1, 0);

to initialize FMOD and FSound. But when I call FSound_DSP_Create I get this error message:
Code: [Select]
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: nFSOUND_DSP_Create
        at org.lwjgl.fmod3.FSound.nFSOUND_DSP_Create(Native Method)
        at org.lwjgl.fmod3.FSound.FSOUND_DSP_Create(FSound.java:3028)
        at PlayDialog$12.actionPerformed(PlayDialog.java:404)
...

Is this my fault, or is this a bug in LWJGL?

WiESi
Logged

WiESi

  • Regular nerd
  • **
  • Offline Offline
  • Posts: 70
FSound_DSP_Create fails
« Reply #1 on: January 15, 2006, 11:13:36 »

Ah, seems to be not implemented in LWJGL. Here's what the C source says:
Code: [Select]
/*
* Class:     org_lwjgl_fmod3_FSound
* Method:    nFSOUND_DSP_Create
* Signature: (I)J
*/
/* Commented out, conflicting declaration with the header */
/*

So, when will this work?

WiESi
Logged

Matzon

  • Demigod
  • *****
  • Offline Offline
  • Posts: 2242
FSound_DSP_Create fails
« Reply #2 on: January 15, 2006, 14:21:17 »

I've been planning on updating the codebase to 3.75 since it got released (as it seems to be the last release). so far I haven't had time and the motivation to do it :(