Hello Guest

ilGenImages throwing exception

  • 2 Replies
  • 7681 Views
ilGenImages throwing exception
« on: November 23, 2005, 23:50:00 »
I get a nasty exception when trying to use devIL to load images into my textures. What obvious things am i missing here? Do i need to init IL somehow prior to envoking ilGenImages?

My code:
Code: [Select]
   IntBuffer cILImage = BufferUtils.createIntBuffer(1);
    IL.ilGenImages( cILImage );

The VM stops when it reaches the ilGenImages.

Console output:
Code: [Select]
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION (0xc0000005) occurred at PC=0x0
Function=[Unknown.]
Library=(N/A)

NOTE: We are unable to locate the function name symbol for the error
      just occurred. Please refer to release documentation for possible
      reason and solutions.


Current Java thread:
at org.lwjgl.devil.IL.nilGenImages(Native Method)
at org.lwjgl.devil.IL.ilGenImages(IL.java:341)
at SpinningBox.loadTexture(SpinningBox.java:218)
at SpinningBox.loadTextures(SpinningBox.java:100)
at SpinningBox.<init>(SpinningBox.java:39)
at SpinningBox.main(SpinningBox.java:33)
bla..bla..bla..


Any insight will be appreciated

*

Offline lightbringer

  • **
  • 50
  • Lone Wolf
ilGenImages throwing exception
« Reply #1 on: November 24, 2005, 00:07:58 »
Most likely you forgot to call IL.create() before going into your texture loading code.

ilGenImages throwing exception
« Reply #2 on: November 24, 2005, 16:47:20 »
Hehe I simply wasn't aware that i needed to call IL.create(). Thanks a bunch lightbringer.