Hello Guest

No 3D sound while using 3D sound

  • 2 Replies
  • 6213 Views
No 3D sound while using 3D sound
« on: October 16, 2005, 17:29:01 »
I was able to get 3D sound working using OpenAL, but if I want to play a sound that isn't 3D (like a click for a menu item) it wants to put that sound in relative 3D space to my listener.  Is there a way to tell OpenAL not to calculate a particular source for 3D?  
The only way I can see to do it so far is to set my listener location, listener orentation, and sound pos to (0, 0, 0) for the non-3D sounds and the correct values for the 3D sounds. That seems like alot of extra OpenAL calls (although I could re-write my sound engine to sort the 3D/non-3D sounds). Any help would be great.  :wink:
Programmers will, one day, rule the world... and the world won't notice until its too late.Just testing the marquee option ;D

*

Offline princec

  • *****
  • 1929
    • Puppygames
No 3D sound while using 3D sound
« Reply #1 on: October 16, 2005, 19:51:49 »
Actually that's exactly how you do it.
Or use stereo sound.

Cas :)

hmmmm...
« Reply #2 on: October 17, 2005, 17:00:06 »
Ok, thanks Cas :D
Programmers will, one day, rule the world... and the world won't notice until its too late.Just testing the marquee option ;D