Hello Guest

LWJGL + JCreator + Windows = ???

  • 7 Replies
  • 13718 Views
LWJGL + JCreator + Windows = ???
« on: September 21, 2005, 19:48:58 »
Anyhow, my title basically says my problem.  Downloaded the archive, and unzipped to C:\ to make the directory C:\lwjgl-win32-0.98

That's all well and good.  Then I open up JCreator, make a new project and delete those place-holder stupid files they give you, and put in a nice demo from the site -- More specifically: FullScreenWindowTest

Ok, still good so far.  I go to Project >> Project Properties and basically follow the instructions EXACTLY on the installation page (The only difference is that I added _util as well since it needed that library).

So I compile... no errors.  That's awesome.  Then I go to run, and I run into your infamous FAQ problem:

Quote
Q: When running the examples or my own program I get a 'Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path.
A: The VM cannot locate the lwjgl runtime library. Specify the path to it using -Djava.library.path='path/to/library'


So I'm like ok kool I didn't mess up this is common.  So then I'm like, hmm... let's see what I can do.  I know it's not compile-time, so I instead go to Configure >> Options >> JDK Tools >> Run Application.  Then I add a new tool here where the only thing I change is the parameter by adding to the end of it:

-Djava.library.path=C:\lwjgl-win32-0.98

So I try to compile and run again... no dice.  I've been trying different combinations of using this path thiing like everywhere in JCreator, but have found no dice.  Can someone help me out?  Thanks in advanced.

*

Offline CaseyB

  • ***
  • 118
LWJGL + JCreator + Windows = ???
« Reply #1 on: September 21, 2005, 20:51:18 »
Why don't you just get eclipse?  It's totally free (not a trial) and it works well!  You can download plugins to do Java, C, C++, XML, all free!  Also it is more common, so you would have an easier time finding people to help you out with IDE specific issues like this!  You can go to eclipse.org and get it and look through the plugins they have there!  You can also google for any other plugin that you want becuase it may have been developed by someone else and therefore not on the eclipse site!

Casey

*

Offline Matzon

  • *****
  • 2242
LWJGL + JCreator + Windows = ???
« Reply #2 on: September 21, 2005, 21:37:13 »
Quote
-Djava.library.path=C:\lwjgl-win32-0.98
isn't the path to the library - it should be:
-Djava.library.path=C:\lwjgl-win32-0.98\native

LWJGL + JCreator + Windows = ???
« Reply #3 on: September 22, 2005, 01:34:01 »
Yeh, I've tried that as well.  the /native.  And I've tried Eclipse, I just prefer JCreator.  =\  I've tried /native and /jar.  Am I putting it in the correct place?

*

Offline Matzon

  • *****
  • 2242
LWJGL + JCreator + Windows = ???
« Reply #4 on: September 22, 2005, 06:15:30 »
since you're extracting to your c drive, I would imagine it should be \native and \jar - not /native

LWJGL + JCreator + Windows = ???
« Reply #5 on: September 22, 2005, 15:16:22 »
Right.  That was a typo in my post.  My bad on that.  But I still can't get anything to run.  The unsatisfiedlink error continues to pester me.

Here is what I have in my parameters for my Run Application JDK Tool:

-classpath "$[ClassPath]" $[JavaClass] -Djava.library.path=C:\lwjgl-win32-0.98\native

Do you guys see anything wrong with that?  I don't really understand what I'm doing wrong.

*

Offline Matzon

  • *****
  • 2242
LWJGL + JCreator + Windows = ???
« Reply #6 on: September 22, 2005, 16:23:37 »
I would do:
-classpath "$[ClassPath]" -Djava.library.path=C:\lwjgl-win32-0.98\native $[JavaClass]
since java might interpret the last argument as an argument to the java app

LWJGL + JCreator + Windows = ???
« Reply #7 on: September 22, 2005, 18:11:36 »
You're awesome.  I love you so long time. =)  Ty very much again.