LWJGL Forum

Archive => DevIL => Topic started by: funkinlocke on January 21, 2008, 11:22:31

Title: error on using devil
Post by: funkinlocke on January 21, 2008, 11:22:31
Hallo to all of you!

I tried lwjgl a few days back, and everything is going down well! I like it!

Now I have a problem with DevIL. I'm using Eclipse and Ubuntu 7.10. I downloaded
the optional package, added the devil-jar-file to my build path and I'm running the jvm
with the following arguments:

Code: [Select]
-Djava.library.path=/home/thomas/Deps/lwjgl-1.1.3/native/linux:/home/thomas/Deps/lwjgl_optional-1.1.3/native/linux

I'm calling IL.create() but DevIL throws an Exception:

Code: [Select]
Exception in thread "main" java.lang.LinkageError: Version mismatch: jar version is '11', native libary version is '7'

Can somebody help me please?

Thanks!


Title: Re: error on using devil
Post by: Matzon on January 21, 2008, 13:52:13
new release following shortly (tonight) that should fix this issue
Title: Re: error on using devil
Post by: funkinlocke on January 22, 2008, 14:08:26
new release following shortly (tonight) that should fix this issue

yeah! with the new version this error doesn't occur! thanks