LWJGL Forum

Archive => DevIL => Topic started by: nicolas_bol2 on April 30, 2006, 03:26:25

Title: Devil on macOS X tutorial crash story...
Post by: nicolas_bol2 on April 30, 2006, 03:26:25
Hello all,

I am trying to use  LWJGL.DevIL on macOS X.

So i downloaded LWJGL on the website, configured classpath and -Dlibrary stuff: Crash.

Ok, so i search a little bit on google and i manage to download MAC OS X libraries on DevIL website.

Then i tried to run the tutorial again: Crash.

Searching on the forum teached me that i need to call IL.create() (http://lwjgl.org/forum/viewtopic.php?t=1407&highlight=nilgenimages)

Ok let's go, but doing so: Crash.

Searching a little bit more, i learned that i need to Call IL.ilInit (http://lwjgl.org/forum/viewtopic.php?t=1330&highlight=nilgenimages)

Ok (i pass on the fact that i had to recompile source because IL.ilInit is private), now it is still crashing am i am running out of "search forum/google" bullets:

java.lang.NullPointerException
   at org.lwjgl.opengl.GL11.glGenTextures(GL11.java:1206)
   at Texture.loadTexture(Texture.java:183)
   at Game.init(Game.java:71)
   at Game.main(Game.java:41)

Line 183 of Texture.loadTexture is:

 GL11.glGenTextures(scratch);

It is a little discouraging....but i won't give up ! Anybody can suggest me something ?
Title: .
Post by: nicolas_bol2 on May 03, 2006, 16:39:27
Whatever, i found a working tutorial on nehe productions.

http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=06
Title: hmmmmmm...
Post by: Fool Running on May 04, 2006, 13:41:40
The crash (if you still care :lol: ) is not caused by DevIL, but more likely as a result of not calling Display.Create().  GL11.glGenTextures() is an OpenGL call, not a DevIL call.
Title: Devil on macOS X tutorial crash story...
Post by: nicolas_bol2 on May 04, 2006, 22:02:23
Thanks "Fool Running"...

Too bad i trashed the old version, there is now way for me to investigate further....

LWJGL really needs to overhaul its tutorial, this is really a bad first impression to begin with a piece of code form the "official" site and it doesn't work.
Title: hmmmmmm...
Post by: Fool Running on May 05, 2006, 19:24:08
Which piece of code did you try to use so someone can look at it?

I looked at a DevIL tutorial on the wiki and I think it assumes you looked at the other tutorials (for calling Display.create() and stuff). The code is designed to be a wrapper for an OpenGL texture object.... Maybe we should be more obvious that the code depends on other code... or at least more knowledge. :)